"Index was out of range" error after repositioning object


I get an index out of range error when I reposition objects whenever the right layer slider is showing a layer above what will become the max layer after moving the object towards the build plate. I guess it’s because the max layer after movement will be a lower number than what is currently shown. I’m using version

I can reproduce it by:

  1. Import an object, place it at some distance above the build table
  2. Slide the right layer slider all the way up to the top layer
  3. Reposition the object downwards toward the build table using one of the movement methods (arrows, 0,H,L-buttons or by using the auto-support feature).
  4. Result is this error:

A workaround is to always remember to keep the layer slider at the bottom position, but it seems to me it should be a temporary workaround.



awesome thanks for the very clear description.
I was able to find it quickly and fix it.
Cause was the rewrite to adaptive layer slicing and some dirty code which is now cleaned and written with some more passive safety.

I’ll upload a fix later today.


Installer is published.


I still get this error if one of the view options “Show islands”, “Display cups” or “Show and calculate exact part-support intersections” are active and one or more objects are below the build plate. Might be more options too but those are the ones I tested.
The error can easily happen if importing objects and the import placement location option is set to “None”, or simply while moving objects around.



thx! got it. It’s happening if parts are dragged completely below Z = 0 right?

last days i’ve managed to improve our exception reporting. So in the future i’m better able to see which line of code generates the error. I had some settings configured wrong for this. So i’m confident i’ll be able to handle errors much more quickly going forward with the next release :smiley:


Yes, dragged below Z=0 or imported directly to a position below the build plate.


thx. got it and handled.


Hi, I’m getting this same error, but it’s occurring immediately opening/importing a specific STL file created in Blender. I’m able to open other files fine but get an error with this one for some reason.


Hi Daniel,

that’s strange. But has to be said i’ve seen some strange stl files coming buy every now and then.
Does it happen with all files from blender? Or just this one?
In both cases, if you want me to take a look at the file please email it to use at info @. Or use wetransfer is to big.



Hi Elco, thanks for the response. I’ve tried a number of stl files now, and encountered the same error on several while others are fine.

From my testing this seems to be some kind of unhandled error relating to size or scale.

I’m encountering the error/crash when importing an STL measuring 0.435 m x 0.294 m x 0.05 m in Blender, with all transformations and modifiers applied, and blender scene units enabled on export (though disabling scene units does not solve the issue).

However I found if I scaled the model up 2x on all axis it will import fine. Scaling the same model back down by .5x will cause the error to reoccur.

I’ll send you an email with a link to the test STL files.

Thanks and kind regards,



This is with the print profile for Anycubic Photon S applied in Formware by the way.


Hi Daniel,

Thx i checked the files. The file that gave the problem was 50 micron high.
The error was thrown in the island/cups detection; which works on a fixed course layer height by default. (i think it runs at 100micron by default).
So if you set this to accuracy setting to ‘high’ for now, it will solve the problem.

For the next release i’ll add a line that does this automatically if the parts are that small.

thx for pointing this out.