Object Reference Not Set to an Instance of an Object


I keep getting that crash report when I tried to slice this stl:

It happens even when you slice it right from the original STL (without hollowing or supports). I ran the STL through Meshmixer and Netfabb STL repair tools but still get the error. I’ve tried to submit it to Formware’s online STL repair tool, but the download keeps stalling at about 21%, and I haven’t been able to get past that. I’ve seen this type of crash several times, and it always seems to happen very quickly when the slicer is first started, for what that’s worth.

Any help on this would be greatly appreciated!

Edit: I used the Peopoly Moai profile. It works fine with the Phrozen Transform.




Thx for reporting this. I’ve looked into it and seems it was caused by the update from V1028 to 1029 somewhen in the middle.

The cause is a new variable for the GCode line; lineformat which is null in your case.
I’ve updated the code to default to this value so this will be there in next update.

For now please enter a value as in the screenshot below and the problem should be gone.
G{0} F{0} X{3} Y{3} Z{3} E{4}



Thanks, Elco. That was quick!