Phrozen Mighty 8k stuck after 1st layer and preview image not working



today tried new Phrozen Mighty 8K, I have 2 issues:

  1. Print starts, printer displays 1st layer image, platform moves up to lift height and then is stuck forever.

  2. Preview image on printer is just piece of pixels, some error

I have made a video, where both problems can be seen. Video here

Formware 1.0.64


Hi Petr,

Did you slice it with the CTB SDK format as a slice format?

Are you able to email/wetransfer me the slice file? (or a dummy?)

It should work without issue.

Stuck forever -> this sounds to me as it might also be a value that is wrong. I.e. something that shoudl be in seconds is in milliseconds.

kind regards


I just double checked the code calling the CTB SDK. I remembered there was a bug once where we missed the milliseconds to seconds conversion. But it has been fixed long time ago.
So the version from the website should be fine in this regard. I can’t check your parameters of course.

kind regards



found the problem. It is in the two stage lift. It works with mini 8k, but does not work with mighty 8k

and when modified to this, then it works

Any idea why the second bug - preview image is wrong?


Hi Petr,

Ok thx for the feedback!

Preview img: i have no idea. Not heard about it before.
the CTB SDK is just uploading 2 bytes per pixel i think.
So one would say; not much could go wrong there :smiley:

Have you tried opening the file in chitubox to see it the preview works there?
Does it also happen with files from chitubox?

And what about updating the firmware on the printer?

kind regards



files sliced in Chitubox are ok. Problem with preview is with files from Formware and same problem is with Lychee ( they say they are working on fixing it )

Sliced file here