Phrozen Sonic Mega 8K


#21

Another problem. The profile is set up like this:

image

The first stage and second stage lift (light blue and dark blue) are working correctly as set up

The retract is not. Instead of dropping 16mm at 300mm/min and then 4mm at 30mm/min, it is dropping 4mm at 30mm/min, then 16 mm at 300mm/min.

This is on both Bottom and Normal layers


#22

Hi Frank,

  • layerNumbers -> I don’t have that many variables in the CTB SDK export. I only have 1 variable which sets the total amount of layers. I checked that in my output and this is the same amount as the number of layer data sets I write. When I read back the file in Formware it’s still the same number.

I do notice that when I open my sliced file in chitubox it first shows 1 layer more in the layer slider; but this corrects as you inspect a layer. So this seems to be something in CTB UI.

Where do you inspect these values you are talking about (as they are not my variable names, neither are they from CTB) ? (are you sure this software is flawless?)

As a background; i’m not putting any value on a certain location in the file. I’m just assigning 1 total value of the amount of layers to a parameters. I have no idea where the CTB SDK writes that to. (and how many places it writes to).

  • totalPrintHeight -> might make sense; as this parameter is not in the SDK. So its probably not used.

The other item with the lift distances i will check for the 4th time… last time I checked the files where the exact same. Maybe something changed or it’s a combination of settings; I don’t know. I have to assume that the descriptions in the CTB SDK are accurate… (of which speed/distance variable is which)… they are not descriptive of which part they are.

Elco


#23

Regarding the speeds and distances.
I tested the following: took a 4mm cube, setup the slicing settings like in your profile. (bottom equal to normal layers)

Then I reload the file and inspect which variables i get:

The ‘Movement’ variables is what it’s about.
The naming convention is the one from CTB.
Basically everything which it denoted with a ‘2’ is the ‘fast’ movement.
Also the layer height variables by default are the sum of the slow+fast part.
The other variable has to be only the ‘fast’ part. (both up and down).

I’ve double checked again the SDK descriptions in their code and PDF manual of the SDK and this is consistent in naming with the ‘2’.

When I do the same setup with chitubox and load the file:

This looks to me as the exact same movement variables.
Iv’e also checked the individual layer variables in our debugger but they are also similar. (derived from the global variables)

To summerize I tested:
Slice FW -> CTB SDK save as .ctb -> CTB SDK read as .ctb -> view file info
Slice CTB -> CTB SDK read as .ctb -> view file info

So don’t really know at this point where it goes wrong…
Perhaps slice a simple cube in both your configurations and send me the files?

For completeness the profiles used:


#24

@formware Hi Elco, you’ve definitely got the retract transposed (And your Chitubox settings in your example are incorrect - see the post below this one). This is a file sliced in Chitubox:

And here are the Chitubox settings:

This is the same file sliced in Formware, with the same settings:

Formware

And here are the Formware settings:

Now if I print the file, the one sliced in Chitubox behaves as expected. However the one sliced with Formware doesn’t - The first part of the retract is 4mm at 30mm/min, the second part is 16mm at 300mm/min.


#25

BTW, my Chitubox settings are correct, yours are incorrect, see the images below.

Not only does the file I sliced in Chitubox behave as expected, but here is the Chitubox documentation regarding two stage (retract only shown, as lift works correctly in Formware):

Chitu_3


#26

Regarding layer counts and total height, they’re not a biggie. I’ve hacked my Mariner3D file handler to deal with them correctly. Strange that they are set by Chitubox, but not exposed in the SDK.


#27

Hi Frank,

Thanks a lot for the clarification. That screenshot of your settings helps a lot as it verifies what the machine does.
I found the problem (and it’s not my fault this time :wink: ) ;
it’s the SDK documentation that is wrong at several places

Just for reference of variable naming, this is the CTB SDK code from CTB (their comments):

This is the CTB SDK pdf documentation:

image

You can see that:
bottomLayerLiftHeight2 -> both of them say it’s fast section, that’s OK.
normalLayerLiftHeight2 -> both of them say it’s fast, thats OK

normalLayerDropHeight2 -> fast vs slow -> so this is wrong.
bottomLayerDropHeight2 -> fast and fast -> _probably this is double wrong then in both docs? as you would assume now that the ‘2’ in the downward movement is the ‘slow’ part every time. _

normalLayerDropSpeed2 / bottomLayerDropSpeed2 -> this is both fast and denoted as slow in the docs.

i’ll fix them asap and test with your CTB settings.

Elco


#28

I’ve fixed the issue. I’ll publish a fix in 1-2 days. Need to finish some other bugs.

Just some other thing I noticed; that adds to the confusion.
If in CTB you use a printer without two stage motion; you have to leave the right column 0.
But that means that the meaning of the left column retract (drop) part changes. Now this is not anymore the fast part, but the slow part… just to add to the overal confusion.


#29

@formware Great, thanks Elco. I’ve worked around it for now by swapping the settings. It works, but it doesn’t look great.

BTW, if you are able to share the SDK documentation with me, I can cross reference it with the info I have regarding the de-encrypted header and possibly come up with more suggestions for fields to use


#30

Hi Frank,
Yeah of course, you could just swap them…

No i’m not allowed to share the documentation… it’s NDA’d
What I shared above in variable naming is I think strictly speaking also not allowed… but for sake of discussion and fixing their problems (of which they benefit if we report it) I think no problem.

Elco


MINI 8K SDK bug ( switched speeds in 2 stage lift / retract mode )
#31

I got my 8K just a couple of days ago, and have printed only a few test figures…
(OK, I only printed the chess piece, then went basolutely bananas…)

Then I printed a pair of ‘White Hare’ miniatures from Moonlight Minis, and all seemed well…
Today It printed the rest of the minis from that set(Alice and the ‘March Hare’), and when I got back home I started the usual cleanup and wash and so on…
Weird… Capital letters on the end of the name tag on the base?
(The minis have integral bases and the names embossed on them)

Every one of them has been mirrored.

The Printer Profile may need a ‘Flip slices in Y direction’