Getting this error when the new version (1.3.5) starts up.

3dMouse (3Dconnexion) initialize function failed.


Same here…
After pressing OK, the application will start fine.


Same with me - don´t have any 3D-mouse installed. Strange


Likewise - no 3d mouse here


This one also did not happen with old version …

I send the report to you

Best regards, Chris


Yes confirmed something strange is going on with this 3d mouse on some PC’s.
I’ll remove the error box and let it die in silence…

The last error Chris, remember when you got it?
It’s faster for us to replicate/fix.



Hey Elco

Got the error during opening a saved file. The file was opened until 21% - then it stuck and gave this

Best regards, Chris


Hi Chris,

Ok. Remember which kind of file?

The other messagebox regarding the DLL for the 3d mouse is removed now.




I tried to open a file saved by formware itself. It was a fw3d file.
Let me check, maybe I can manage to get the old file. In the meantime I made this
file new, and the problem did not occur anymore.

Best regards, Chris


Hey Elco

Now I get this one with that file. That is the recently newly saved file …

best regards, Chris


Hi Chris,

Are you able to send me the file over email?
I can check if for you.

We rewrote the entire project file structure. So with V1035 the entire file is a different structure. It should however be able to read the old files.
Speed up is the main reason for this.



Hi Chris,

For all other readers here.
The bug was found and fixed.
It was caused by special characters in the part names (i.e. Umlauts) not being read back correctly.
As of today files that had this problem can be read again.



Hi Elco

Thanks for quick fixing.
Is that fix already included in the installer on the website? It still says 1.0.35 by 12/03/2021?

Best regards, Chris


aah something went wrong FTPpublishing. Fixed it now.