Hello, I want to thank you for the awesome slicer first of all.
I would love to be able to export to .CXDLP format for the HALOT ONE printer directly from Formware 3D. I am tired of having to use UVTOOLS to do an export.
Thank you!

PS> I know there are two other posts with the same request. I just want to show that there are more people waiting for this feature. By the way I do own a Formware 3D License =) Merry Christmas.


ok thx for bringing it up!

I’m about to integrate the CTB SDK as well; just received documentation etc.
So I will do my best to take this one and the longer 4k also along in the same go.



Hello, still no .CXDLP after February update :cry:


yeah… sorry. CTB and photonworksshop too some more time to do well.
I’ll have a look upcoming week.

You can always just use UVtools and link it after slicing to convert the file.


fyi… i’ve started implementation.


I’ve updated our installer today with the CXDLP file export.
Supports now the Halot One, Sky, Max and Lite.

kind regards


Thank you for adding .cxdlp and Halot One printer.
but The file sliced to .cxdlp will not load to the printer, the printer states “this model does not match the printer.”


Hi Gonzalo,

Can you email me the file you are trying to print? Or an example file?

Do you have the latest firmware installed on the printer?

I’ve build the export (in binary content) similar to UVTools exports.

Can you try his software to see if you can read the file?

kind regards


Hello Elco, thank you for all your help. My file exported from Formware3d as .CXDLP is read ok by UVTOOLS, I use UVTOOLS all the time. UVTOOLS exports to .CXDLP just fine too. (i choose v2 and the machine reads it ok)
But if I export to .CXDLP from Formware3D the file will fail when I send it to the printer. The message: “this model does not match the printer.” appears as soon as I load it.
I tried to upload the file here for you to check it out, but “new users cannot upload files” thing appears. What is your email so I can send it to you?
Thank you.



I see in the previous release notes that you list the HALOT SKY, MAX and LITE ONE, not the HALOT ONE… is that the problem? Is the HALOT ONE any different in file format?


Hi Gonzalo,

You are 100% right. I see it wrote the wrong printer type in the file.
Printer type is based on resolution X/Y when it’s exported.
But resolution was not set yet; so it defaulted to a wrong printer type.
I’ve corrected it and will upload the installer in 1min.

kind regards


Yes! it works! now it slices to .CXDLP and the machine loads and prints perfectly.
Thank you so much for your hard work!


Since the last couple of updates from both you and Ceality, the files still do load and print, but some of the print parameters don’t seem to push over to the printer. Meaning, I slice and export just fine, and the file loads just fine on the printer, but if I select “file parameters” on the printer UI, it does not load anything, so I have to use “printer parameters”. this applies only to the parameters that can be controlled on the machine interface screen like exposure time, base layers exposure time, base layer count, lift distance, rest time before and after, and motor speed. Other parameters, basically all the pre-processing and post-processing seem to work fine. So, everything under the tab “Movement & Exposure” is not pushing over or is been overwritten by the printer?
Please let me know if you need more information to look at this.

Thank you



Hi Gonzalo,

So the creality slicing software also has this issue?



Sorry if I confused you. UVTools and Halot Box do export files correctly. Formware 3D, exports the sliced geometry but no print parameters at all.


more info: i imported the formware sliced file (.cxdlp) into UVTools, and changed some parameters and exported in both v2 and v3 .cxdlp. when loading into the Halot One, v2 will do the same as the formware file which is not reading the exposure time or anything else, just the geometry. v3 will change the exposure time to 1s regardless of whatever the value was before. so there is an issue of the printer reading formware or uvtools files?



There is still the same issue with .CXDLP files for the Creality Halot One printer.
For the Formware 3D sliced file to load correctly, I am:

  1. Loading the sliced file into UVTOOLS
  2. Changing the Exposure Time field to the intended value in TENTHS OF A SECOND. so 2.5s = 25 for example. (I think these fields can not be decimals and that’s why they use a 1/10th of a second unit?)
  3. Exporting to CXDLP V3. since V2 will not work.

This way everything loads correctly in the printer.
Is there a way that you can fix this?
Please let me know if I can help.